Contact Us | (123) 456-7891

Forum

HomeHomePLC ProgrammingPLC ProgrammingGEGEGE PID ProblemGE PID Problem
Previous
 
Next
New Post
2/26/2009 9:12 PM
 
I have a GE 90-30 CPU 374 PLUS. The program currently has a PID controller that controls a valve. I would like to add a second PID controller to control fans. However I am having a problem implementing the 2nd PID controller. When I upload the program and run it, all the parameters are constantly changing. The P,I and D gains fluctuate, upper/lower clamps, etc are changing. The original controller still functions properly. Moreover, if I remove the old controller (mixing valve) and run it, the new fan controller now runs fine. I ensured that the controllers each have enough reserved memory (40 words). Has anyone had any similar problem?
 
New Post
2/27/2009 6:39 AM
 

Sounds like something is being overwritten.  Are you sure the new PID addresses are not used elswhere? Have you done an implicit search?

 
New Post
3/2/2009 2:53 PM
 

Are you using Proficy ME to program?  The 374's are known to be a little flaky, even though they are the highest-end CPU you can get for a 90-30 platform.  Are you using PID in ladder, or in a FBD?

 
New Post
3/2/2009 3:12 PM
 

turns out i did have something that was overwriting the PID registers

 
New Post
4/2/2011 6:45 PM
 

I am a newbie at setting up a PID loop. I am getting 2 errors and cannot download. 8141 unexpected instruction. 8149 missing power flow.

I need some type of sample to get  this project test going. I am using a versamax micro / nano IC200UAL006. My GEXPRO support has been out of town all week and I turning to the PLC forum. Anyone?

 
Previous
 
Next
HomeHomePLC ProgrammingPLC ProgrammingGEGEGE PID ProblemGE PID Problem